Fastly and Let's Encrypt

Comments

3 comments

  • Gabe_Roffman

    Not seeing any reply to this. I'm also trying to get Fastly to reverse proxy to my LetsEncrypt secured backend but always getting a sslv3 alert handshake failure. Anyone get around this?

    0
    Comment actions Permalink
  • Rogier Mulhuijzen

    Using any cert on your backend should not be a problem. If you are getting errors, please contact support@fastly.com with the exact error, but before you do that, check that your backend supports TLS 1.0 at a minimum, and preferably TLS 1.2.

    0
    Comment actions Permalink
  • Gabe_Roffman

    Found the solution was needing to specify SNI hostname and to specify Cyphersuites as ECDHE-RSA-AES256-GCM-SHA384 under the Advanced TLS options.

    0
    Comment actions Permalink

Please sign in to leave a comment.