[Fixed]Issues with ESI

Comments

1 comment

  • astingengo

    Found the problem. The encoding should be disabled (it is enabled by default). In order to do that: sub vcl_miss { unset bereq.http.accept-encoding; }

    Also, to enable ESI only for html content type I use:

    sub vcl_fetch {
      if (beresp.http.content-type ~ "text/html*") {
        esi;
      }
    }
    

    Hope this will help others.

    Regards, Astin

    0
    Comment actions Permalink

Please sign in to leave a comment.