Fastly, Google Cloud Functions & 503 SSL handshake error



  • Rogier Mulhuijzen

    The 503 means that there was a handshake error when trying to connect to origin. Can you show me what your Origin settings are in the Fastly service you set up?

    Comment actions Permalink
  • Rowan Savage

    One of the great support staff at fastly @Richard_Alpagot figured it out.

    The SNI had to be set to the same as the Certificate hostname.

    E.g. Origins -> Host Host: TLS options: Certificate hostname: SNI hostname:

    Settings -> Override Host:

    I will play with the settings and configure it right and then make an update on what the best settings are.

    Comment actions Permalink
  • Brian Flood


    I'm trying to setup fastly in front of google cloud functions as well, do you have any more info on your setup? domain, address/hostname, SNI values you used? the KeyCDN content you posted above seems to be depreciated, is your setup still working?

    thanks! brian

    Comment actions Permalink

Please sign in to leave a comment.